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Introduction to CTTP 
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The CTTP 2000 Data Browser 
CTPP is a set of special tabulations designed for transportation planners from the decennial census. CTPP contains 
tabulations by place of residence, place of work, and for flows between home and work. 
  
CTPP is the only Census product that summarizes data by place of work and provides information on the travel flow 
between home and work. 
It is the only source of information provided by the Census Bureau with summary tabulations available for Traffic Analysis 
Zones (TAZs) and other small geographic areas. 
  
CTPP 2000 is sponsored by the State Departments of Transportation under a pooled funded arrangement with the 
American Association of State Highway and Transportation Officials (AASHTO).  
  
What is new in CTPP 2000? 
  

�   Improved employer coding 
�  State TAZs added as a geographic reporting level 
�  TAZs included in TIGER/ Line well before tabulation stage 
�  Greater use of Geographic Information Systems (GIS) and database formats 
�  New tables to aid emerging planning issues 
�  Potential for custom tabulations 
�  Speedier delivery 

  
CTPP 2000 data access plan 
  

�  User- friendly program to extract data 
�  Choose tables by topic area 
�  Point + click row and column summaries 
�  GIS for data query and mapping 
�  Export data to database formats 
�  Output data to GIS useable formats 

  
  
Where can I get more information? 
  
Call the CTPP Hot line at: 
  
202- 366- 5021 
  
http:// www. mcs. com/~ berwyned/ census/ 
  
Listserv: To subscribe, send an e- mail to majordomo@ chrispy. net with the body as “Subscribe ctpp- news”. 
  
E mail: ctpp@ fhwa. dot. gov 
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Create Session 
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Creating Sessions in the CTTP Data Browser 
Select File > Create Session 
  

 
  
Selecting the Create Session option will open the following window requiring the user to name the Data and Session Path 
and to give the current session project a name. 
Click OK. The Create Session Interface Window will open. 
  

 
  

  The browse buttons to the right of the path names can be used to find folder locations.  
  
Click OK. 
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Using the Create Session Interface Window 
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Create Session Interface Window 

  
1. Select a Geographic Type. 
2. Select Features 
3. Display Geography/ Selected Features 
4. Previous/Next 
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Select Geographic Type 

 
  
 Clicking the Pull Down Arrow displays the list of shapefiles available for selection. 
  
Here, Block Groups have been selected and are now available in the Select Features section of the interface. 
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Select Features 

  
The user may select features by checking the appropriate box.  In this example, the counties are listed. The Display 
Geography tab has been selected which allows the user to view the selections made in map format.  The map indicates 
that Sherman County has been selected. All selections are colored in red. 
  
The plus signs adjacent to the county names indicates that more information is available.  In this instance, clicking on the 
plus sign will display the block groups contained within Sherman County.  The user may now select individual block 
groups. Once a block group(s) is (are) selected they are displayed in red on the map. The cursor will indicate the name 
and number of the county which parallels the Select Features list. 
  
The user may choose to Select the Entire Level or Unselect a particular level using the buttons underneath the Select 
Features list. 
  
Click Next to move into the next phase of the session, Working with Tables. 
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Display Geography 

 Selecting this tab allows the user to view selected features they have chosen from the Select Features list in map format.  
  

 
  
 The Viewing tools at the bottom of the map can be used to pinpoint certain areas of the map. 

�  Zoom In - Enlarges the map to view areas in more detail. 
�  Zoom All - Returns map to its full view. 
�  Pan Map - Allows the user to navigate to certain areas of the map. 
�  Select Feature -  Allows the user to use the cursor to click and select certain features of the map for analysis. 

The feature will be checked off in the Select Features List and the selection will be indicated on the map in red. 
  
In the following window, the Select Feature viewing tool has been activated. As the cursor navigates over the map, it will 
identify each particular County and  block group. Click on the county and/or block group of interest to select it. 
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The following window illustrates that Sherman County has been selected on the map and is also checked off in the Select 
Features list.  
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Display Main Roads 

 
  
Display Main Roads option is available.  Simply check the Display Main Roads box to activate it.  
  
The following map illustrates the new view with the Main Roads included. 
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Selected Features 

Clicking the Selected Features tab will display which features have been selected from the Select Features List. 
  

  
All selections can be cleared using the Clear All button.  Individual selections can be cleared from the list. Highlight the 
selection and click Clear Selected. 
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Previous/Next 

  
Once the selections are made, click Next to move on to Working with Tables. 
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Working with Tables 
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Session Tables Window 

  
Once the geographic features have been selected, tables can be generated. 
  
1. Select Table - Clicking the folders opens the list of tables of data available. 
  
2. Select Tables - Once the table is selected, the title of the table is named and the contents are listed with the Table # 
and the number of Cells it contains.  
  
3. Selected Tables - Lists the tables that have been selected. 
  
4. Previous/Finish - Previous allows access back to the Create Session Window which displays the selected geography. 
 Finish takes the user into the Open Session Table Window. 
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Select Table 

The Select Table portion of the window displays the folders that contain the tables to access.  
  

 
  
Opening a folder will list the tables that are available.  Click on a table to access the fields of data. See Select 
Tables/Universe for more information. 
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Universe 

  
Selecting a table from the available folders will display the table information in the Select Tables window (See #2). The 
name of the table is displayed (See Universe: All Households) .  The Table #, Content and # of Cells is listed within the 
window. 
  
Click on a particular table to view a description of the Table Fields.  In this example, the table of Household Size data is 
highlighted. The fields are listed in the Description Window.  Use the scroll bar to view all of the table fields. 
  

The Select All Button is available to select all the tables. 
  

The Clear Selection Button returns the list of table back to its original state. 
  
Click on the Selected Tables tab to view a list of the tables which have been chosen. 
  
Once the tables have been selected, click Finish to move on to Open Session Table. The Previous button, will allow 
access back to the geography screen. 
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Selected Tables 

Lists the Tables that have been selected from the Select Tables List.. 
  

 



 31

Previous/Finish 

  
Previous allows access back to the Create Session Window which displays the selected geography.  
  
Finish takes the user into the Open Session Table Window. 
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Key Word Search 

This tool allows the user to search table fields to locate pertinent data. 
  

 
  
Enter the Key Word in the space provided. Clicking the Pull Down Arrow will open the list of fields that contain the Key 
Word. 
  
In the following example, the Key Word "Hispanic" drew two matches which is noted ; "Found 2 Matches". The Pull Down 
List names the two matches found within the tables. Select the appropriate match and click "Search". 
  

 
  
Here, "Hispanic Origin" was selected as the table of interest.  The table is then located and highlighted by the program. 
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Display Map 
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MAPViewer 
Once a table has been generated, the Display Map tool will depict the table data in map format. 
  

  
1. MAPViewer Pull Down Menus 
2. MAPViewer Tool Options 
3. MAPViewer Legend 
4. Map View 
5. Map Index 
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MAPViewer Legend 
# 3 - The Map Legend lists the layers of shapefiles that are available for viewing within the Map View. 
 Clicking a layer box will display or remove a layer from the map view. 
  
In this Map View, all layers are visible. 
  

  
  
The following map displays the new map view with the Water shapefile turned off in the Map Legend. 
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Map View 
The Map View (see #4) displays the current map extent in use. The Map Legend dictates which shapefiles are used to 
create the map.. 
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Map Index 
The Index Map displays the map view at full scale with the zoomed features indicated by a red box. (See #5). As the Map 
View is changed the Index Map red box will shift accordingly. 
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MAPViewer Pull Down Menus 
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File 



 42

MAPViewer File Pull Down Menu 

 
  
Export Map Data 
Map Layout 
Print Preview 
Printer Setup 
Print 
Return to Tables 
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Export Map Data 
File > Export Map 
  
This allows the user to save map selections for export and use in other programs. The following window will open to name 
the map selection. The file will be saved as a shapefile, (*.SHP) extension. 
  

 
  
This map depicts the county of interest. 
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This map depicts the current selection, colored in royal blue, as well as two previous areas of the map that had been 
exported. Checking off the Test10 and Test8 layers would leave the Test11 map. 
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 46

Map Layout 
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Map Layout Configuration Window 
File > Map Layout 
  

 
  
The Map Layout option allows the user to customize the map configuration for printing.  The following window will open. 
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Map Scale 
The user may choose to select the "Fit The map to the current page size" option simply by checking the box. 
  

 
  
Or the user may choose to set the map scale.  An error message will appear if the scale cannot be used.  
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Map Title 
Map Titles can be made within the Map Layout Configuration Window.  In this example, the map is titled "Sherman 
County". 
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Map Edits 
Edits can be made to map elements. Click on the element to move and /or resize the image using the corner boxes. 
  

 
  
Here, the map title has been relocated.  
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Print Preview 
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Print Preview 
File > Print Preview 
  
Allows the user to preview the current window for printing.  
Select Map Layout, Spreadsheet or Graph. If no edits are necessary, the user may choose to Print the current window.  
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Map Layout 
File > Print Preview > Map Layout 
  
Allows the user a view of the map before printing. If no map has been created, the following message window will open. 
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Spreadsheet 
File > Print Preview > Spreadsheet 
  
Allows the user to view the spreadsheet before printing.  If no spreadsheet has been created, a message window will 
appear reminding the user to create one. 
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Graph 
File > Print Preview> Graph 
  
Allows the user a view of the graph before printing.  If no graph has been created, a message window will open reminding 
the user to create one. 
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Printer Setup 
File > Printer Setup 
  
By selecting the setup printer option under the File Pull Down Menu, the following menu will appear: 
  

 
  
The user can select from a list of available printers using the scroll down menu. 
  
By clicking the Properties button, the user can access various edits to customize the print. 
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Print 
 File > Print. 
  
Prints the active window.  
  
Select Print Map Layout, Spreadsheet or Graph. 
  
If the settings for the printer are correct, CTPP MAPViewer will print the current window. 
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Return to Tables 
File > Return to Tables 
  
Returns user to the Tables Session Window.  
  
  
  

 
  
This option is also available with the tool menu by clicking the Return to Tables button. 
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Edit 
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MAPViewer Edit Pull Down Menu 
The Edit Pull Down Menu allows the user to copy the current map, speadsheet or graph into the windows clipboard. The 
files can then be pasted. 
Note: The Copy Spreadsheet and Copy Graph options will be grayed out unless they are in current use. 
  

 
  
Copy Map 
Copy Spreadsheet 
Copy Graph 
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Copy Map 
Edit > Copy Map (.bmp or .emf) 
  
Copies the current map on to the windows clipboard.  The file can then be pasted to another location. The Copy 
Spreadsheet and Coppy Graph options will be grayed out unless they are in current use. 
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Copy Spreadsheet 
Edit > Copy Spreadsheet 
  
Allows the user to copy the current spreadsheet on to the windows clipboard. It can be pasted later to another location. 
Note: The option will be grayed out if a spreadsheet is not open. 
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Copy Graph 
Edit > Copy Graph 
  
Allows the user to copy the current graph on to the windows clipboard. It can be pasted later to another location. Note: 
The option will be grayed out if a graph is not open. 
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Selection 
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Selection Pull Down Menu 

 
  
Configure 
Clear Selection 
Zoom to Selected 
Select by SQL 
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Configure 
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Configure 
Selection > Configure 
  
The Configure Window allows the user to customize what selections and how the selections will be made within the map 
view.  
  

 
  
1. Selection Layer - The user chooses which layer or shapefile they will be using for selection. 
  
2. Selection Options  - Selection Color, Selection Drawing Tools, Buffer, Display Selection 
  
3. Selection Method  - Intersect or Within 
  
Click Done when the selections are made.  
  
  
  

Note: The Select Map Features Tool   must be engaged to make the selections on the map. 
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Selection Options 
Selection Options allow the user choices as to how selections will be made within the Map View. 
  

 
  
Changes to selection color, the type of draw tool,  the buffer distance around the draw tool and how the selection is 
displayed can be customized. 
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Selection Color 
The Selection Color and Outline Color can be changed by clicking the color box.  The color palette will open. 
  

 
  
  
The following window and corresponding map displays the new color option used for the outline color.  
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Selection Drawing Tools 
Using the Draw Selection as a Box option, the cursor is used to draw a box containing the area of the map that is to be 
selected. 
  
Here, one selection has been made and another box has been drawn to indicate that a different selection is in progress.  
Only one selection will be displayed at a time. 
  

 
  
The following window depicts the use of the polygon draw tool in progress. 
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Buffer 
The Select Buffer tool allows selection of an area surrounding a straight line. Use the cursor to start the line and double-
click when the line is complete.  Use Clear Selection to undo selections made.  When a new line is drawn, the previous 
selection will be cleared. 
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Display Selection 
The following windows display the options of displaying the selection on the map as an outline or as a graphic. 
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When both options are selected, the drawing of the selection is made visible. 
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Selection Method 

 
  
# 3 - Selection Method gives the user the choice to select objects that intersect the lines of the selection outline or select 
objects that are contained completely within the selection outline. 
  
Note: For the second option, if no object is contained completely within the selection outline, no selection will be 
displayed. 
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Clear Selection 
 Selection > Clear Selection 
  
Allows the user to clear any selections made within the map view.  
  

This option is also available on the tool bar. Click the Clear Selected Features Button.   
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Zoom to Selected 
Selection > Zoom to Selected 
  

The Zoom to Selected Features button can also be used.    

The Zoom to Previous Extent button can be used to return the map to the previous view.  
  
This option allows the user to select a certain area of the map  to view more closely. 
  

 
  
Here, the Select Box tool was used to select this portion of the map and the Zoom to Selected Tool enlarged and centered 
the selected feature. 
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Select by SQL 
Selection > Select by SQL 

This option is also available by clicking the Select Features Using SQL tool.  
  
The SQL Dialog box will be opened. 
  

 
  
Select an attribute from the Fields list  on the left (see #1). Only fields available within the project's database will be 
available. 
  
The Field that is selected will be described underneath the Fields List (see # 3).  Here, the LONGLAB field has been 
selected which is described as the "Full Name for Each Feature". 
  
The user may choose a value that is available within that field in two ways. Clicking the Show Values option (see # 2) will 
display all the values contained within that particular database field.  Note: Only fields which have less than 10,000 values 
will be listed. The process of pulling up all of the available values for a field can be time consuming.  The other option for 
choosing values is to name the values that are of interest. For example, the areas that contain populations that have more 
than 2000 whites. 
  
Select any boolean operators from the Operators keys to produce a query.  
  
The query that has been created will be displayed in the Query Syntax Box (see #4) 
  
By selecting the Test button, the query will be tested on the data before executing. The test will return the number of 
features in the active theme that would be selected by the query. If the number of selected features is not adequate, the 
query can be modified and tested again. If the selection test was acceptable then select Apply. Click OK to return to the 
map view. Selected features will appear in yellow.  
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Advanced Tools 
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Advanced Tools Pull Down Menu 

 
  
Add User Themes 
Remove User Themes 
Customize Theme 
Spreadsheet Format Cell(s) 
Spreadsheet Properties 
Spreadsheet Options 
Graph Wizard 
Graph Designer 
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Add User Themes 
Advanced Tools > Add User Themes 
  
Allows the user to add a shapefile to the map legend.  
  
The following window will open allowing the user to browse and name a new shapefile to add to the map. 
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Remove User Themes 
Advanced Tools > Remove User Themes 
  
Select themes or shapefiles that have been added to the map legend for removal. 
  
Note: Only User themes can be removed.  The following window will open as a reminder. 
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Customize Theme 
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Customize Theme 

  
This tool allows the user to create maps with customized features. Each tab addresses different aspects of the map. 
  
Value 
Dot 
Chart 
Labels 
 Layer Properties 
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Value Options 
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Value 
Single Color 
Polygons within a theme can be colored based on three different methods. Each of these methods has a different set of 
parameters. 
  

  
Outline and fill colors and patterns can be modified. 
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By changing the fill style from solid to vertical fill, the map's selected feature is altered from a solid fill of the selected color 
to a vertical fill of the selected color.  To select a fill color, click on the Fill Color section which will bring up a palette. 
  
Load allows the user to access previously saved legend parameters to apply to the current map view. 
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Value 
Group by Color 

  
Polygons are colored based on a grouping scheme, contained as an attribute within the data base. In the example above, 
counties are grouped based on state name. 
Choose the attribute for grouping from the Field draw-down menu. (See # 3). A color scheme can be chosen from the 
color legend box. In this example, the color scheme that is selected is named Random Colors.  Once the color scheme is 
selected click Display Legend (See # 1).  The colors associated with that scheme are displayed and numbered in the 
Legend Color Preview Screen (see #2).  The color and size of the outlines on the map can be altered by clicking the Edit 
Outline button. (See # 4).  The keys at the bottom of the legend color preview screen allow the user to edit the colors that 
are available. (See # 5). 
  
The options available are: Remove, Clear All, Add Existing Value, Add All and Update.  Once a color is selected it can be 
removed. All of the colors can be cleared. Use Add existing Value to return any deleted colors to the screen.  Update 
allows the user to alter a selected color. 
  
Load allows the user to access previously saved legend parameters to apply to the current map view. 
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Value 
Graduated Color 

  
Graduated Color maps allows for data to be classified. Under the Classification menu, select an attribute to classify and 
select a number of classes to be made. Select a classification method. Then select Display Legend to preview the 
classes. Next select a start and end color by double-clicking each box and selecting a new color. Select Display Legend 
again to preview color scheme. Once satisfied with the classification and color scheme, select Apply to make changes to 
the map view. The legend color preview screen allows the user to edit the colors selected for the map.  Select a color in 
the preview screen and then click the bottom button (The Update key).  A color palette will appear allowing the user to 
choose a different color. 
  
Load allows the user to access previously saved legend parameters to apply to the current map view. 
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Dot 
Dot Density 
 Dot density maps can be drawn based on attributes from the data base. 

  
To create a dot density map, first select the Draw Dot density box. Then select a field from the Density Field draw-down 
list. Each dot will default to a value of 1000. For example,  if the density field were population, each dot would represent 
1000 people. This value can be modified. Select a dot color and size. Finally select the Apply button to generate the dot 
density map. Layer statistics will appear on the window. 
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Chart 
 Charts can be either pie or bar charts. 
  
  

  
Both types require the same parameters. 
  
First select the list of desired attributes from the Fields menu, selecting Add after each choice. The optional Size Field 
regulates the size of the pie, based on a chosen attribute. The Normalize By field can be used to normal the values by a 
defined attribute. Normalizing a factor is to modify it's contribution to the total based on the magnitude of it's contribution. 
For example, a pie composed of each racial category can be modified by area to represent population density. When all 
desired parameters are set, select the Apply button. 
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Labels 

  
  Label properties are set within this dialog box. Two methods are available, Standard and Advanced. 
   
Standard 
Standard options are shown above. The text field is used to select an attribute to use to label. Horizontal and vertical 
alignment can be set. Font selection is made here.  Scale features can be selected. 
  
  
Advanced 
Advanced features are shown below: 
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Layer Properties 

  
Attribute properties can be viewed in the Layer Properties window. 
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Spreadsheet Format Cell(s) 
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Spreadsheet Format Cell(s) 
Advanced Tools > Spreadsheet Format Cells 
  
Number 
Alignment 
Font 
Border 
Patterns 
Protection 
Validation 
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Number 
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Alignment 
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Font 
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Border 
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Patterns 
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Protection 
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Validation 

 
  



 108

Spreadsheet Properties 
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Spreadsheet Properties 
Advanced Tools > Spreadsheet Properties 
  
View 
Edit 
Selection 
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View 
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Edit 

 



 112

Selection 
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Spreadsheet Options 
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Spreadsheet Options 
Advanced Tools > Spreadsheet Options 
  
General 
Calculation 
AutoFill 
Spreadsheet Color 
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General 
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Calculation 
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Auotfill 
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Spreadsheet Color 
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Graph Wizard 
Right-Click on a graph to bring up the Graph Wizard option. The following gallery of graph types is available for 2D and 
3D graphing. Select a chart type from the menu and select next. 
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Graph Designer 
After right-clicking on a graph, the Graph Designer option becomes available .By clicking the graph designer tool, the 
following box appears: Edits can be made to the graph. 
  
 

 
  

 
  



 121

 



 122

Help 
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Help Contents 
Allows user access to Help information. 
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About 
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MAPViewer Tools Menu 
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MAPViewer Tool Options 

  
Return to Tables Button 
  

 
  
MAPViewer View Tool Options 
  

 
  
Create Thematic Map Tool 
  

 
  
Display Analysis Window Tool 
  

 
  
Identify Tool 
  

 
  
Selection Tool Options 
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Return to Tables Button 

 
  
This button returns the user back to the tables session window. This option is also available within the File Pull Down 
Menu. 
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MAPViewer View Tool Options 
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MAPViewer View Tool Options 

 
  
Zoom to Full Extent Button 
Zoom to Session Extent Button 
Draw Box or Click to Zoom In Tool 
Drag Box or Click to Zoom Out Tool 
Pan Map Tool 
Zoom to Previous Extent Button 
Zoom In 10% Button 
Zoom Out 10% Button 
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Zoom to Full Extent Button 

 
  
This button brings the map view out to it's fullest extent. 
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Zoom to Session Extent Button 

 
  
This button zooms the map to the extent of work for the current session. 
  

 
  
Note: The Index Map will display the current session map within the larger extent. 
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Drag Box or Click to Zoom In Tool 

 
  
This tool allows the user to pinpoint specific areas within the map view to zoom.  Click to engage and disengage the tool. 
  

 
  
Map View after Zoom In Tool is engaged. 
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Note: The Index Map will display the new map view within the full extent map. 
  

 
  

 
  
The Zoom to Previous Extent Button will return the map back to the previous view.  
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Drag Box or Click to Zoom Out Tool 

 
  

 
  
Map after zoom out tool engaged. 
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Note: The Index Map will display the new map view within the full extent map. 
  

 
  

 
  
The Zoom to Previous Extent Button will return the map back to the previous view.  
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Pan Map Tool 

 
  
The Pan Map Tool , once engaged, will allow the user to click and drag the map to view different areas. 
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Zoom to Previous Extent Button 

 
  
This button will return the map to its previous extent. 
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Zoom in 10% Button 

 
  
Clicking this button will zoom the map in 10%. 
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Zoom Out 10% Button 

 
  
Clicking this button will zoom out the map by 10%. 
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Create Thematic Map Tool 
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Create Thematic Map Tool 

 
  

 
  
Map Parameters: 
  
Color 
Fill Style 
Number of Classes 
Field 
Description 
  
Default 
Advanced 
Edit Legend 
Labeling 



 142

Map Parameters 
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Color 
Making changes to the color and fill style depicts the change in the default map to the new map.  

 
Default Map 
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Fill Style 
Allows the user to change the style of the thematic map to depict 
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Number of Classes 
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Field 
  



 149

Description 
  



 150

Default 
Sets the map back to it's original version. 
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Advanced 
Opens the Customize theme window to edit more map features. 
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Edit Legend 
The Edit Legend tool allows the user the ability to change colors which depict different data on the map. 
  

 
  
Clicking the Edit Legend Button will bring up the following window.  Each field color can be customized. Click on the field 
then click Color to open color palettes. 
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Edits can also be made to the field data Break Points. 
Click on the field and then click Edit. 
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Labeling 
The Labeling Pull Down Menu allows the user the ability to select different field names to be displayed within the map 
selection. 

 
  

 
  
Here, the County identification numbers have been selected. 
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Display Analysis Window Tool 



 158

Display Analysis Window Tool 

 
  
The Display Analysis Button allows the user access to data to be viewed in Graph and Table format.  
  

 
  
The Options Pull Down Menu allows for saving and opening of table configuration. 
  

 
  
See Graph and Table for views of data that has been configured. 
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Display Analysis Graph 
The Graph Tab within the Display Analysis Window will depict the table data in graph form.  
  
Right-clicking on the graph will open the Graph Options. 
  

 
  
Chart Designer 
Edit Chart Data 
Wizard 
Open 
Save As 
Print 
Copy 
Paste 
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Graph Options 
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Chart Designer 
After right-clicking on a graph, the Chart Designer option becomes available .By clicking the Chart Designer tool, the 
following box appears: Edits can be made to the graph. 
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Edit Chart 
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Open 
Navigate to a previously saved graph, and select it for opening. Graphs must be in CTTP format to open properly. 
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Save As 
Provide a path and file name to save the current graph to.  
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Print Graph 
Opens the following window to set up the print of the graph. 
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Copy 
Copy the current graph. 
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Paste 
Paste the current graph. 
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Display Analysis Table 
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Identify Tool 

 
  
Clicking the Identify Tool will allow the user to obtain record information relating to specific areas of the map. 
  
The current project will be listed in the Identify from Layer draw down menu.  Click on the draw-down arrow to display the 
layers that are currently available on the map legend.  The user may select which layer of geography they would like to 
identify.   
  
  

 
  
In this case, the counties shapefile has been selected.  
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Selection Tool Options 
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Selection Tool Options 

 
  
Select Map Features 
Clear Selected Features 
Select Features Using SQL 
Zoom to Selected Features 
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Select Map Features 

 
  
This tool is used in conjunction with the Selection Configure Window. 
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Clear Selected Features 

 
  
Allows the user to clear any selections made within the map view.  
  
This feature is also available within the Selection Pull Down Menu. 
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Select Features Using SQL 

 
  
Selecting the SQL Query Builder icon from the tool menu launches the SQL Query Builder dialog box. 
  

 
  
Select an attribute from the Fields list  on the left (see #1). Only fields available within the project's database will be 
available. 
  
The user may choose a value that is available within that field in two ways. Clicking the Show Values option (see # 2) will 
display all the values contained within that particular database field.  Note: Only fields which have less than 10,000 values 
will be listed. The process of pulling up all of the available values for a field can be time consuming.  The other option for 
choosing values is to name the values that are of interest. For example, the areas that contain populations that have more 
than 2000 whites. 
  
Select any boolean operators from the Operators keys to produce a query.  
  
The query that has been created will be displayed in the Query Syntax Box (see #4) 
  
By selecting the Test button, the query will be tested on the data before executing. The test will return the number of 
features in the active theme that would be selected by the query. If the number of selected features is not adequate, the 
query can be modified and tested again. If the selection test was acceptable then select Apply. Click OK to return to the 
map view. Selected features will appear in yellow.  
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Zoom to Selected Features 

 
  
This feature is also available within the Selection Pull Down Menu. 
  
This tool allows the user to select a certain area of the map to view more closely. Note: A selection must be made in order 
to engage this tool. 
  

 
  
Here, the Select Box tool was used to select this portion of the map and the Zoom to Selected Tool enlarged and centered 
the selected feature. 
  



 178
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A Guide to the User Interface 
Type topic text here. 
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Close Session 
Type topic text here. 
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Copy Session 
Type topic text here. 
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Create Session 
Type topic text here. 
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Display Field 
Type topic text here. 
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Display Chart 
Type topic text here. 
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Edit Session 
Type topic text here. 
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Exit 
Type topic text here. 



 187

Next Label 
Type topic text here. 
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Open Existing Session 
Type topic text here. 
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Open Session 
Type topic text here. 
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Open Session Table 
Type topic text here. 
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Remove Session 
Type topic text here. 
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Search 
Type topic text here. 
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Sort 
Type topic text here. 
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The File Pull Down Menu 
Type topic text here. 
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The Open Session Table Window 
The Open Session Table window contains the tables of data selected in the Session Tables Window. 
  

 
  
Each group of tables can be accessed simply by highlighting the group of interest. The previous table displays the first 
group of  tables selected from "At Residence" folder:  All Persons. The following window displays the second group. 
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Highlighting a specific table (1) will display the table information in the Title (2) section of the window. 
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Once, the table is selected, click OK to view and work with the table data. (See The Table Data Window). 
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The Table Data Window 
Once the Geography and the particular Field has been selected, the data pertinent to that certain area is available in table 
format. 
  

  
1. Pull Down Menus 
2. Accessing Information Tools 
3. Field Data Pull Down 
4. Identify, Print and Display Tools 
5. Table Data 
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Tile 
Type topic text here. 
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